Topics

F20d


Wilhelm Derner
 

Hi All. 
Has anyone had my tractor problem? When you use the front loader for, say half an hour it stops functioning. I have, change the oil. Checked the level when hot, but it still refuses to pump after a time. Where should I look next. Thanks

--
Wil Bear.


Scotty
 

Probably your hydraulic filters are clogged.
1. Drain the oil.
2. Clean & reinstall the reusable screen filter under the triangular cover.
3. Replace the spin-on Hydraulic filter. 
4. Replace the oil with trans/hydraulic fluid
Start it up. Check for leaks. The pump flow will automatically purge any air from the system 
good luck
rScotty

On Mar 18, 2021, at 3:40 AM, Wilhelm Derner via groups.io <wderner@...> wrote:

Hi All. 
Has anyone had my tractor problem? When you use the front loader for, say half an hour it stops functioning. I have, change the oil. Checked the level when hot, but it still refuses to pump after a time. Where should I look next. Thanks

--
Wil Bear.


KC2GIU
 

Will,

rScotty's advice is good.  Just with the F-FX Series machine, it could be a triangle plate near the back by the PTO spindle OR it could be as a canister just before the rear axle under the tractor.  Yanmar has done these 2 ways in various models in the past and with the JD counter part models too. 

I'm not certain if Karl made a custom OPS and maintenance manual for the F20.  I'll have to check and see.  Then you'll need to cut-and-paste in any online translator from Czech to English. Karl's details are really good. 

Steve